package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$`)
var str = `tuan201200387@st.utc.edu.vn
tuan@gmail.com
Tuan_123@gmai.edu.com
tuan?123@gmail.vn
!@$#@$^$@^%123Tun.edu.vn
Tuan#$#%^%#^@#@.vn
Tuan.vn
abCdEF@.edu.@#%^$^$.vn
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}