use strict;
my $str = 'tuan201200387@st.utc.edu.vn
tuan@gmail.com
Tuan_123@gmai.edu.com
tuan?123@gmail.vn
!@$#@$^$@^%123Tun.edu.vn
Tuan#$#%^%#^@#@.vn
Tuan.vn
abCdEF@.edu.@#%^$^$.vn
';
my $regex = qr/^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}