using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w-]+@[\w]+(\.[a-z0-9]{2,4}){1,3}$";
string input = @"tuan201200387@st.utc.edu.vn
tuan@gmail.com
Tuan_123@gmai.edu.com
tuan?123@gmail.vn
!@$#@$^$@^%123Tun.edu.vn
Tuan#$#%^%#^@#@.vn
Tuan.vn
abCdEF@.edu.@#%^$^$.vn
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}