using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(OTS_BOOL_FNT_BEGIN\()(_T\()?(""(?:\.|(\\\"")|[^\""\n])*"")(\)\)?\;?)";
string substitution = @"CTrzFunc trace(false, m_pTrace,$3);\nbool bFNTRdo = true;";
string input = @"OTS_BOOL_FNT_BEGIN(_T(""CGPKCardSession::OpenSession""))";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}