package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(OTS_BOOL_FNT_BEGIN\()(_T\()?("(?:\.|(\\\")|[^\""\n])*")(\)\)?\;?)`)
var str = `OTS_BOOL_FNT_BEGIN(_T("CGPKCardSession::OpenSession"))`
var substitution = "CTrzFunc trace(false, m_pTrace,$3);\nbool bFNTRdo = true;"
fmt.Println(re.ReplaceAllString(str, substitution))
}