$re = '/(OTS_BOOL_FNT_BEGIN\()(_T\()?("(?:\.|(\\\\\")|[^\""\n])*")(\)\)?\;?)/m';
$str = 'OTS_BOOL_FNT_BEGIN(_T("CGPKCardSession::OpenSession"))';
$subst = "CTrzFunc trace(false, m_pTrace,$3);\nbool bFNTRdo = true;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;