const regex = /(OTS_BOOL_FNT_BEGIN\()(_T\()?("(?:\.|(\\\")|[^\""\n])*")(\)\)?\;?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(OTS_BOOL_FNT_BEGIN\\()(_T\\()?("(?:\\.|(\\\\\\")|[^\\""\\n])*")(\\)\\)?\\;?)', 'gm')
const str = `OTS_BOOL_FNT_BEGIN(_T("CGPKCardSession::OpenSession"))`;
const subst = `CTrzFunc trace(false, m_pTrace,$3);\nbool bFNTRdo = true;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);