re = /(OTS_BOOL_FNT_BEGIN\()(_T\()?("(?:\.|(\\\")|[^\""\n])*")(\)\)?\;?)/m
str = 'OTS_BOOL_FNT_BEGIN(_T("CGPKCardSession::OpenSession"))'
subst = 'CTrzFunc trace(false, m_pTrace,$3);\\nbool bFNTRdo = true;'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result