import Foundation
let pattern = #"(OTS_BOOL_FNT_BEGIN\()(_T\()?("(?:\.|(\\\")|[^\""\n])*")(\)\)?\;?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"OTS_BOOL_FNT_BEGIN(_T("CGPKCardSession::OpenSession"))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"CTrzFunc trace(false, m_pTrace,$3);\nbool bFNTRdo = true;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)