// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(OTS_BOOL_FNT_BEGIN\()(_T\()?("(?:\.|(\\\")|[^\""\n])*")(\)\)?\;?)"#).unwrap();
let string = "OTS_BOOL_FNT_BEGIN(_T(\"CGPKCardSession::OpenSession\"))";
let substitution = "CTrzFunc trace(false, m_pTrace,$3);\\nbool bFNTRdo = true;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}