#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?-(.+?)-?_.*"
Local $sString = "veiculos-sao-paulo-__4--6--.html" & @CRLF & _
"veiculos-parana__4--6--.html" & @CRLF & _
"veiculos-rio-de-janeiro-__4--6--.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)