// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?-(.+?)-?_.*").unwrap();
let string = "veiculos-sao-paulo-__4--6--.html
veiculos-parana__4--6--.html
veiculos-rio-de-janeiro-__4--6--.html";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}