package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?-(.+?)-?_.*`)
var str = `veiculos-sao-paulo-__4--6--.html
veiculos-parana__4--6--.html
veiculos-rio-de-janeiro-__4--6--.html`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}