const regex = /.*?-(.+?)-?_.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*?-(.+?)-?_.*', 'gm')
const str = `veiculos-sao-paulo-__4--6--.html
veiculos-parana__4--6--.html
veiculos-rio-de-janeiro-__4--6--.html`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);