import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?-(.+?)-?_.*";
final String string = "veiculos-sao-paulo-__4--6--.html\n"
+ "veiculos-parana__4--6--.html\n"
+ "veiculos-rio-de-janeiro-__4--6--.html";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}