# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\.{2,}|(?<=[^\s.]))$/./gm;t' <<< "python...is...fun...
python...is...fun
python...is...fun??
test
"