import re
regex = re.compile(r"(?:\.{2,}|(?<=[^\s.]))$", flags=re.MULTILINE)
test_str = ("python...is...fun...\n"
"python...is...fun\n"
"python...is...fun??\n\n"
"test \n")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)