const regex = new RegExp('(?:\\.{2,}|(?<=[^\\s.]))$', 'gm')
const str = `python...is...fun...
python...is...fun
python...is...fun??
test
`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);