use strict;
my $str = 'python...is...fun...
python...is...fun
python...is...fun??
test
';
my $regex = qr/(?:\.{2,}|(?<=[^\s.]))$/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";