#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^\h*<!--|(?<!\A|-->\n)\G).*\R"
Local $sString = "<!-- text1" & @CRLF & _
" text2" & @CRLF & _
" text3" & @CRLF & _
"" & @CRLF & _
" text4" & @CRLF & _
"-->" & @CRLF & _
"" & @CRLF & _
"ext" & @CRLF & _
"" & @CRLF & _
"text"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)