import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^\\h*<!--|(?<!\\A|-->\\n)\\G).*\\R";
final String string = "<!-- text1\n"
+ " text2\n"
+ " text3\n\n"
+ " text4\n"
+ "-->\n\n"
+ "ext\n\n"
+ "text";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}