use strict;
my $str = '<!-- text1
text2
text3
text4
-->
ext
text';
my $regex = qr~(?:^\h*<!--|(?<!\A|-->\n)\G).*\R~mp;
my $subst = '\\n';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";