using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^\h*<!--|(?<!\A|-->\n)\G).*\R";
string substitution = @"\n";
string input = @"<!-- text1
text2
text3
text4
-->
ext
text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}