$re = '~(?:^\h*<!--|(?<!\A|-->\n)\G).*\R~m';
$str = '<!-- text1
text2
text3
text4
-->
ext
text';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;