re = /(?:^\h*<!--|(?<!\A|-->\n)\G).*\R/m
str = '<!-- text1
text2
text3
text4
-->
ext
text'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result