#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!(<link|<!--)).+$"
Local $sString = "<link href='G:/Using/mdCss/style.css' rel='stylesheet' /> More words" & @CRLF & _
"<link href='./style.css' rel='stylesheet' />" & @CRLF & _
"<!-- some random header info -->" & @CRLF & _
"<!-- ctrl a dont select above -->" & @CRLF & _
"" & @CRLF & _
"This is the content." & @CRLF & _
"Some random sentences." & @CRLF & _
"More content with <link in it"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)