re = /^(?!(<link|<!--)).+$/m
str = '<link href=\'G:/Using/mdCss/style.css\' rel=\'stylesheet\' /> More words
<link href=\'./style.css\' rel=\'stylesheet\' />
<!-- some random header info -->
<!-- ctrl a dont select above -->
This is the content.
Some random sentences.
More content with <link in it'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result