const regex = /^(?!(<link|<!--)).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(<link|<!--)).+$', 'gm')
const str = `<link href='G:/Using/mdCss/style.css' rel='stylesheet' /> More words
<link href='./style.css' rel='stylesheet' />
<!-- some random header info -->
<!-- ctrl a dont select above -->
This is the content.
Some random sentences.
More content with <link in it`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);