$re = '/^(?!(<link|<!--)).+$/m';
$str = '<link href=\'G:/Using/mdCss/style.css\' rel=\'stylesheet\' /> More words
<link href=\'./style.css\' rel=\'stylesheet\' />
<!-- some random header info -->
<!-- ctrl a dont select above -->
This is the content.
Some random sentences.
More content with <link in it';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;