import re
regex = re.compile(r"^(?!(<link|<!--)).+$", flags=re.MULTILINE)
test_str = ("<link href='G:/Using/mdCss/style.css' rel='stylesheet' /> More words\n"
"<link href='./style.css' rel='stylesheet' />\n"
"<!-- some random header info -->\n"
"<!-- ctrl a dont select above -->\n\n"
"This is the content.\n"
"Some random sentences.\n"
"More content with <link in it")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)