using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(<link|<!--)).+$";
string substitution = @"$2";
string input = @"<link href='G:/Using/mdCss/style.css' rel='stylesheet' /> More words
<link href='./style.css' rel='stylesheet' />
<!-- some random header info -->
<!-- ctrl a dont select above -->
This is the content.
Some random sentences.
More content with <link in it";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}