# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.+?) ?\b(\d{4})\b(.*?)$/$2 $1$3/gim;t' <<< "Visiting relatives 2010
2017 trip
Old photos from 2001
Old 2002 photos
"