const regex = new RegExp('^(.+?) ?\\b(\\d{4})\\b(.*?)$', 'gim')
const str = `Visiting relatives 2010
2017 trip
Old photos from 2001
Old 2002 photos
`;
const subst = `$2 $1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);