// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(.+?) ?\b(\d{4})\b(.*?)$").unwrap();
let string = "Visiting relatives 2010
2017 trip
Old photos from 2001
Old 2002 photos
";
let substitution = "$2 $1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}