import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?) ?\\b(\\d{4})\\b(.*?)$";
final String string = "Visiting relatives 2010\n"
+ "2017 trip\n"
+ "Old photos from 2001\n"
+ "Old 2002 photos\n";
final String subst = "$2 $1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}