use strict;
my $str = 'Visiting relatives 2010
2017 trip
Old photos from 2001
Old 2002 photos
';
my $regex = qr/^(.+?) ?\b(\d{4})\b(.*?)$/imp;
my $subst = '$2 $1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";