re = /^(.+?) ?\b(\d{4})\b(.*?)$/im
str = 'Visiting relatives 2010
2017 trip
Old photos from 2001
Old 2002 photos
'
subst = '$2 $1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result