#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)http:\/\/(www\.[a-z0-9]+([\-\.][a-z0-9]+)*\.[a-z]{2,5})(:[0-9]{1,5})?(\/.*)?$|^(\/.*)"
Local $sString = "http://www.google.com" & @CRLF & _
"/~germain/CS4480" & @CRLF & _
"http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1" & @CRLF & _
"http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1" & @CRLF & _
"" & @CRLF & _
"http://www.cs.utah.edu:8080/~germain/CS4480" & @CRLF & _
"" & @CRLF & _
"http://www.cs.utah.edu/~germain/CS4480"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")