using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/(www\.[a-z0-9]+([\-\.][a-z0-9]+)*\.[a-z]{2,5})(:[0-9]{1,5})?(\/.*)?$|^(\/.*)";
string input = @"http://www.google.com
/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1
http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1
http://www.cs.utah.edu:8080/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}