import Foundation
let pattern = #"http:\/\/(www\.[a-z0-9]+([\-\.][a-z0-9]+)*\.[a-z]{2,5})(:[0-9]{1,5})?(\/.*)?$|^(\/.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.google.com
/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1
http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1
http://www.cs.utah.edu:8080/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)