import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http:\\/\\/(www\\.[a-z0-9]+([\\-\\.][a-z0-9]+)*\\.[a-z]{2,5})(:[0-9]{1,5})?(\\/.*)?$|^(\\/.*)";
final String string = "http://www.google.com\n"
+ "/~germain/CS4480\n"
+ "http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1\n"
+ "http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1\n\n"
+ "http://www.cs.utah.edu:8080/~germain/CS4480\n\n"
+ "http://www.cs.utah.edu/~germain/CS4480";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}