package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/(www\.[a-z0-9]+([\-\.][a-z0-9]+)*\.[a-z]{2,5})(:[0-9]{1,5})?(\/.*)?$|^(\/.*)`)
var str = `http://www.google.com
/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1
http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1
http://www.cs.utah.edu:8080/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}