// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http:\/\/(www\.[a-z0-9]+([\-\.][a-z0-9]+)*\.[a-z]{2,5})(:[0-9]{1,5})?(\/.*)?$|^(\/.*)").unwrap();
let string = "http://www.google.com
/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1
http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1
http://www.cs.utah.edu:8080/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}