const regex = new RegExp('http:\\/\\/(www\\.[a-z0-9]+([\\-\\.][a-z0-9]+)*\\.[a-z]{2,5})(:[0-9]{1,5})?(\\/.*)?$|^(\\/.*)', 'gm')
const str = `http://www.google.com
/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480 HTTP/1.1
http://www.cs.utah.edu/~germain/CS4480:8080 HTTP/1.1
http://www.cs.utah.edu:8080/~germain/CS4480
http://www.cs.utah.edu/~germain/CS4480`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}