using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+\.\w+)""";
string input = @"<span>emoticon12</span><img src=""qrc:\res\emoticon\emo12.gif"" width=""20"" height=""20""/><span>emoticon8</span><div>...</div><img src=""qrc:\res\emoticon\emo8.gif"" width=""20"" height=""20""/>...<img src=""qrc:\res\emoticon\emo9.gif"" width=""20"" height=""20""/>...";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}