re = /(\w+\.\w+)"/m
str = '<span>emoticon12</span><img src="qrc:\\res\\emoticon\\emo12.gif" width="20" height="20"/><span>emoticon8</span><div>...</div><img src="qrc:\\res\\emoticon\\emo8.gif" width="20" height="20"/>...<img src="qrc:\\res\\emoticon\\emo9.gif" width="20" height="20"/>...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end