// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\w+\.\w+)""#).unwrap();
let string = "<span>emoticon12</span><img src=\"qrc:\\res\\emoticon\\emo12.gif\" width=\"20\" height=\"20\"/><span>emoticon8</span><div>...</div><img src=\"qrc:\\res\\emoticon\\emo8.gif\" width=\"20\" height=\"20\"/>...<img src=\"qrc:\\res\\emoticon\\emo9.gif\" width=\"20\" height=\"20\"/>...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}