import re
regex = re.compile(r"(\w+\.\w+)\"", flags=re.MULTILINE)
test_str = "<span>emoticon12</span><img src=\"qrc:\\res\\emoticon\\emo12.gif\" width=\"20\" height=\"20\"/><span>emoticon8</span><div>...</div><img src=\"qrc:\\res\\emoticon\\emo8.gif\" width=\"20\" height=\"20\"/>...<img src=\"qrc:\\res\\emoticon\\emo9.gif\" width=\"20\" height=\"20\"/>..."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")