use strict;
my $str = '<span>emoticon12</span><img src="qrc:\\res\\emoticon\\emo12.gif" width="20" height="20"/><span>emoticon8</span><div>...</div><img src="qrc:\\res\\emoticon\\emo8.gif" width="20" height="20"/>...<img src="qrc:\\res\\emoticon\\emo9.gif" width="20" height="20"/>...';
my $regex = qr/(\w+\.\w+)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}