import Foundation
let pattern = #"(\w+\.\w+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<span>emoticon12</span><img src="qrc:\res\emoticon\emo12.gif" width="20" height="20"/><span>emoticon8</span><div>...</div><img src="qrc:\res\emoticon\emo8.gif" width="20" height="20"/>...<img src="qrc:\res\emoticon\emo9.gif" width="20" height="20"/>..."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)